WordPress auf MAC OS X Server mit SSL

Diesmal war es ein Kampf.
Nachdem ich gelesen hatte, das ab nächstem Jahr alle Webseiten durch eine neue EU-Richtline sicherer gemacht werden sollen, habe ich mich dazu entschlossen die Sci-Fy auf SSL umzustellen.

Da das ganze hier mit einem MAC OS X Server läuft, hatte ich mir ausgemalt, daß es relativ einfach sein wird. Pustekuchen, war es eben nicht.

Zuerst bin ich hergegannen und habe den alten Indianer (Apache) auf SSL umgestellt. Das geht realtiv einfach, indem man die httpd-ssl.conf in der httpd.conf bearbeitet und aktiviert. Dazu gibt es genügend saubere Dokus im Netz. Ich habe mir dann eine statische Seite aufgebaut, um zu testen, ob SSL dann klappt. So weit so gut. Klappt :-)
Danach ging es dann an Wp. Das musste jetzt auch umgestellt werden. Also habe ich dann einige Webseiten durchforstet, und es hieß, man müsse nur in den Einstellungen von WP die URL ändern. Da jede Seite so gut wie das selbe schrieb, kam der Gedanke auf, daß sich alles in 10 Minuten erledigt hätte.

Nixda. Wp spielte verrückt. Entweder kam ein weiße Seite oder das Theme, was installiert war, spielte total verrückt. Nix klappte. Darauf hin habe ich dann ein paar Freunde kontaktiert, die sich mir PHP auskannten. Unter anderm den FreeBSD Onkel :-) und einige andere. Nichts schien zu klappen. Wir hatten probiert die wp-config.php zu bearbeiten, aber das klappte auch nicht. Einige Teile wurden per Port 443 geladen der Rest über Port 80. Dadurch bekam ich unter dem Schloß, was links oben in der Adresszeile steht, immer den Hinweis, daß einige Daten nicht sicher geladen werden.

Bin dann in das WPDE Forum und habe da mal meine Anfrage reingestellt. Nach langem hin und her ist dann die Firma Kessler-Design auf den Fehler gekommen.

Das einzige was hier geholfen hat, war ein Fix in der .htaccess. Un der sieht so aus

# BEGIN UMLEITUNG
<IfModule mod_rewrite.c>
RewriteEngine On
# Check the ways it could have been https…
RewriteCond %{HTTPS} =on [OR]
RewriteCond %{SERVER_PORT} ^443$ [OR]
RewriteCond %{SERVER_PORT} ^34543$ [OR]
RewriteCond %{HTTP:X-Forwarded-Proto} https [NC]
# …and if it was https, then set HTTPS
RewriteRule .* – [E=HTTPS:on]
</IfModule>
# END UMLEITUNG

Nach dem der dann eingesetzt worden war, klappte alles zu 95 %. Jetzt muss man lediglich noch die DB umstellen, so das alle Inhalte per https geladen werden. Und das geht am besten mit dem Plugin Better Search Replace.  Vor der Umstellung sollte dieses Plugin installiert werden. Das Plugin aufrufen und die Tabellen durchsuchen lassen.  Im oberen Feld kommt die http-Adresse inkl. Domain rein und im unteren Feld https inkl. Domain. Dann erst mal einen Testlauf machen. Wenn alles gut aussieht, den Haken bei Test raus nehmen und noch mal den Durchlauf machen.

Woran lags?

Eigentlich einfach wenn man es weiß. WP verwendet Absolute Pfade und keine relativen. Dadurch kommt es zu dem unschönen Fehler. Nach der Umsetzung lief alles

Ich bin jetzt froh, daß es jetzt über SSL läuft und muss jetzt lediglich dafür sorgen, das das SSL-Zertifikat immer aktuell ist.

UPDATE07.06.17

nach ein paar tagen war komischer Weise das SSL in der Adressleiste verschwunden. Habe darauf hin folgendes gemacht

Dazu musst du lediglich die folgende Zeile in deine wp-config.php Datei einfügen.

define(‚FORCE_SSL_ADMIN‘, true);

Fügt die Zeile oberhalb von dieser Zeile ein:

/* That’s all, stop editing! Happy blogging. */

Danach ging alles wieder

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Captcha * Time limit is exhausted. Please reload CAPTCHA.

This site uses Akismet to reduce spam. Learn how your comment data is processed.